Change background image
LOVE quotion

Bắt đầu từ 4.53' thứ Hai ngày 17/10/2011


You are not connected. Please login or register

Xem chủ đề cũ hơn Xem chủ đề mới hơn Go down  Thông điệp [Trang 1 trong tổng số 1 trang]

Zone
Zone Ưu tú

Cấp bậc: Ưu tú

Bài viết : 792

Danh vọng : 1476

Uy tín : 0

Hệ điều hành RouterOS

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Cd1110


  • Mikrotik RouterOS là hệ điều hành được xây dựng cho kiến trúc phần cứng RouterBoard của Mikrotik (công ty thuộc nước Cộng hòa Latvia . Hệ điều hành RouterOS được xây dựng với đầy đủ các chức năng như định tuyến (router), tường lửa (firewall), quản lý băng thông, AP, liên kết mạng trục, quản lý Truy cập Mạng Công cộng (có dây hoặc không dây), thiết lập VPN, ...
  • RouterOS là một hệ điều hành chuẩn dựa trên nền Linux v2.6, cung cấp tất cả những tính năng của bộ định tuyến cộng với khả năng cài đặt nhanh chóng, đơn giản và giao diện sử dụng dễ dàng.


Kiến trúc phần cứng

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrot10


  • Hệ điều hành RouterOS hỗ trợ kiến trúc phần cứng đa lõi (multi-core) và đa CPU (multi-CPU), có thể hoạt động ổn định trên kiến trúc Mainboard lớn và hiện đại nhất của Intel cùng với các chip CPU đa lõi mới nhất.
  • Hệ điều hành RouterOS có thể hỗ trợ cài đặt trên các thiết bị lưu trữ USB, SATA, IDE bao gồm HDD, SDD, thẻ nhớ SD, CF… và cần ít nhất 64Mb dung lượng trống để cài đặt.
  • Bên cạnh đó, nó có thể hỗ trợ nhiều loại cổng giao tiếp mạng bao gồm các card Ethernet 10Gb mới nhất, bảng mạch Wireless 802.11a/b/g/n và modem 3G…


Định tuyến (Router)

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-7

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-8


  • Hệ điều hành RouterOS hỗ trợ nhiều giao thức định tuyến như: với IPv4 là RIP v1/v2, OSPF v2, BGP v4 hoặc với IPv6 là Ripng, OSPFv3, và BGP.
  • Hỗ trợ định tuyến và chuyển tiếp theo kiểu mạch ảo (Virtual Routing and Forwarding), định tuyến dựa theo chính sách thực thi, định tuyến dựa trên cổng giao diện mạng hoặc định tuyến ECMP.
  • Hệ điều hành RouterOS cũng hỗ trợ nghi thức MPLS cùng với công nghệ định tuyến và chuyển tiếp kiểu mạch ảo (Virtual Routing and Forwarding). VRF là công nghệ mà cho phép thiết lập nhiều thể hiện của một bảng định tuyến (routing table) cùng tồn tại trong cùng thời điểm tại cùng một bộ định tuyến. Các thể hiện nầy là độc lập, bởi vậy trong cùng thời điểm, các địa chỉ IP cho dù trùng hay chồng lấn nhau vẫn có thể được dùng mà không mâu thuẫn nhau. VRF cũng thường được dùng để nâng cao an ninh mạng, nhưng nó không hạn chế chỉ với nghi thức  MPLS.


Tường lửa (Firewall)

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-5

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-6


  • Tính năng Firewall được xây dựng cho các nhiệm vụ lọc gói tin và thực thi các chức năng an ninh, quản lý lưu lượng vào ra hay ngăn chặn các truy cập chưa được chứng thực…
  • Hỗ trợ NAT các địa chỉ nguồn, địa chỉ đích cho các ứng dụng và UPnP, cung cấp các tính năng theo dõi kết nối, định tuyến, đánh dấu gói tin.
  • Xây dựng chức năng lọc thông qua địa chỉ IP, lớp mạng, các port hoặc giao thức IP, các thông tin phù hợp lớp 7…


Quản lý Truy cập Mạng Công Cộng (Hotspot Gateway)

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-16


  • Chức năng: Quản lý Truy cập Mạng Cộng Cộng (Hotspot) thực hiện việc việc xác thực, phân quyền và ghi chép (AAA) thông tin hoạt động của người dùng Mạng Công Cộng, bất kể họ sử dụng thiết bị kết nối có dây hoặc không dây. Người dùng sử dụng trình duyệt Web sẽ được đưa đến một Trang Chào và để có thể truy cập Mạng Công Cộng, người dùng phải đăng nhập với tài khoản được cấp (thường là username/ password).
  • Lợi ích: Quản lý Truy cập Mạng Cộng Cộng (Hotspot) phù hợp để triển khai Mạng WiFi Công Cộng tại sân bay, trường học, quán café Internet, khu vui chơi, khu thương xá, siêu thị, hội chợ triển lãm,.. Đây là những nơi đòi hỏi nhà quản trị mạng không những phải quản lý người dùng truy cập mạng (AAA - xác thực, phân quyền và ghi chép thông tin hoạt động) mà còn không được can thiệp vào máy tính của người dùng (không cho phép cài đặt bất kỳ phần mềm hoặc cấu hình gì). Mâu thuẫn nầy được giải quyết nhờ chức năng Quản lý Truy cập Mạng Công Cộng (Hotspot) của RouterOS thông qua việc cấp tài khoản cho người dùng để đăng nhập tại Trang Chào.
  • Xác thực: Chức năng Quản lý Truy cập Mạng Công Cộng hỗ trợ xác thực dựa trên máy chủ RADIUS chuẩn. Nhà quản trị có thể sử dụng RADIUS sẵn có bên trong RouterOS hoặc tự thiết lập RADIUS bên ngoài. Hiện nay, Mikrotik cũng có sẵn User Manager (RADIUS server) của riêng hãng. Với User Manager, nhà quản trị có khả năng quản lý tập trung người sử dụng trong toàn bộ hệ thống mạng WiFi của doanh nghiệp trải rộng tại nhiều Phòng, Ban và Chi nhánh khác nhau trên toàn quốc.
  • Phân quyền: Chức năng Quản lý Truy cập Mạng Cộng Cộng quản lý dựa trên các hồ sơ dịch vụ của người dùng được tạo ra bao gồm: thời lượng và thời hạn sử dụng, giới hạn tốc độ upload và download, ...
  • Đặc trưng tổng quát

    • Xác thực người dùng bằng nhiều phương pháp khác nhau trên cơ sở dữ liệu lưu trữ trên OSRouter hoặc trên máy chủ RADIUS bên ngoài.
    • Ghi chép thông tin truy cập của người dùng vào cơ sở dữ liệu lưu trữ trên OSRouter hoặc trên máy chủ RADIUS bên ngoài.
    • Cấu hình bypass cho các thiết bị không tương thích
    • Cho phép truy cập một số trang Web hữu ích (walled garden) mà không cần xác thực người dùng.
    • Dể dàng thay đổi nội dung Trang Chào để quảng cáo thương hiệu doanh nghiệp.



Máy chủ Ủy thác Web (Web Proxy Server)

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-webproxy


  • Hệ điều hành RouterOS có thể thực hiện vai trò Máy chủ Ủy thác Web (Web Proxy server) để lưu trữ tạm (cache) các nguồn tại nguyên Web dưới dạng các file sao lưu (copied and cached files) và nhờ đó tăng tốc độ duyệt Web của người dùng khi có yêu cầu cùng nội dung. Máy chủ Ủy thác Web trên RouterOS thực hiện các chức năng sau:

    • Ủy thác HTTP thông thường (Regular HTTP Proxy) - Nhà quản trị mạng cấu hình chỉ định Máy chủ Ủy thác trên RouterOS và người dùng cấu hình chĩ định Máy chủ Ủy thác trên trình duyệt Web của máy tính.
    • Ủy thác HTTP trong suốt đối với người dùng (Transperent HTTP Proxy) - Người dùng hoàn toàn không biết có Máy chủ Ủy thác hoạt động và họ cũng không thay đổi bất kỳ cấu hình gì trên trình duyệt Web của máy tính.
    • Danh sách truy cập (Access List) - Thiết lập các quy tắc để duyệt hoặc không duyệt danh sách Web được yêu cầu (tương tự như tường lửa) theo địa chỉ nguồn, theo địa chỉ đích, theo URL và theo các phương thức yêu cầu HTTP (GET, HEAD,...). Nếu phù hợp với quy tắc, một tác động (action) tương ứng với quy tắc sẽ được thực thi.
    • Danh sách Lưu trữ tạm (Cache Access List) - Xác định các đối tượng (tên miền, máy chủ, trang web..) có thể được lưu nhớ tại Máy chủ Ủy thác.
    • Danh sách Lưu trữ tạm trong máy chủ Ủy thác đang xử lý (Direct Access List) - Xác định tài nguyên nào truy cập trực tiếp tại máy chủ Ủy thác đang xử lý hoặc truy cập thông thông qua một máy chủ Ủy thác khác.
    • Danh sách Kết nối (Connection List) - Danh sách các kết nối hiện tại mà Máy chủ Ủy thác đang phục vụ.
    • Phương  tiện Ghi chép (Logging facility) - Cho phép lấy và lưu trữ các thông tin liên quan đến hoạt động của Máy chủ Ủy thác.
    • Ủy thác đối với các yêu cầu theo nghi thức SOCKS.
    • Hỗ trợ Máy chủ Ủy thác mẹ (Parent proxy support)
    • Lưu trữ tạm (Cache) trên ổ đĩa bên ngoài.


  • Tại các mạng WiFi Công Cộng (WiFi Hotspot), hệ điều hành RouterOS có thể vừa Quản lý Truy cập Mạng mà vừa hoạt động như một Máy chủ Ủy thác Trong suốt đối với người dùng (Transparent Proxy server). RouterOS sẽ tự động lấy các yêu cầu HTTP từ trình duyệt Web của người dùng, chuyển hướng yêu cầu đến Máy chủ Ủy thác cục bộ (Local Proxy server) và nhờ đó giúp tăng tốc độ duyệt Web đáng kể mà không cần thay đổi cấu hình trong trình duyệt Web của người dùng, đặc biệt là khách vãng lai.

                                           
Chất lượng Dịch vụ (QoS)

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-chatluongdichvu-1

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-chatluongdichvu-2


  • Kiểm soát băng thông, thiết lập các cơ chế kiểm soát tốc độ dữ liệu cấp phát, độ trễ, độ tin cậy mạng.
  • Cấu hình ưu tiên hay định hình lưu lượng mạng:

    • Giới hạn tốc độ dữ liệu cho từng IP, subnet, giao thức, port cụ thể và các thông số khác.
    • Giới hạn lưu lượng peer-to-peer
    • Ưu tiên luồng gói tin
    • Sử dụng hàng đợi cho duyệt web nhanh hơn
    • Áp dụng hàng đợi trong các khoảng thời gian nhất định
    • Chia sẻ băng thông lưu lượng người dùng đồng đều hoặc tùy thuộc tải của kênh



Phần mềm Quản lý Thiết bị - The Dude

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-thedule


  • The Dude là phần mềm giám sát mạng, sẽ tự động quét các thiết bị trong mạng con được chỉ định, vẽ và xây dựng một sơ đồ mạng lưới, theo dõi dịch vụ của các thiết bị mạng và cảnh báo khi các dịch vụ gặp vấn đề.
  • Không chỉ có thể theo dõi các thiết bị RouterOS mà còn có thể theo dõi bất kỳ thiết bị nào có thể truy cập bằng cách ping, hoặc cung cấp thông tin SNMP.
  • Cho phép đưa ra các biểu đồ lưu lượng, báo cáo nghẽn gián đoạn, và thậm chí thể hiện như một SysLog server lưu trữ các Log file thiết bị.
  • The Dude cũng có thể quản lý cấu hình RouterOS thiết bị mạng của bạn, tự động nâng cấp phần mềm và cấu hình hàng loạt thiết bị.
  • The Dude là một phần mềm ứng dụng miễn phí.


Cấu hình Thiết bị

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-3

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-4


  • RouterOS hỗ trợ nhiều phương thức cấu hình thông qua cổng Serial Console kết nối terminal, Cấu hình với giao diện GUI thông qua công cụ Winbox, cấu hình dựa trên giao diện web hoặc cho phép xây dựng chương trình API tạo ra một ứng dụng điều khiển… Ngoài ra RouterOS cũng hỗ trợ kết nối dựa trên lớp MAC với khả năng tùy chỉnh được thực hiện bởi công cụ MAC-Telnet và Winbox.


Đẩy dữ liệu (Forwarding)

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-9

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-10


  • Hệ điều hành RouterOS hỗ trợ chuyển tiếp lớp 2 (Layer2 forwarding) bao gồm Bridging, Mesh và HWMP+. Với HWMP+ là một giao thức định tuyến mới cho mạng vô tuyến Mesh, cải thiện HWMP (Hybrid Wireless Mesh Protocol) trong chuẩn dự thảo 802.11s.
  • Sử dụng công nghệ (R)STP có thể loại bỏ các địa chỉ MAC trùng  được nhìn từ nhiều port Bridge bằng cách vô hiệu hóa port thứ cấp tới địa chỉ MAC. Điều này giúp chống loop và cải thiện độ tin cậy của mạng.


Nghi thức MPLS

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-11

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-12


  • MPLS là chuẩn chuyển mạch nhãn đa giao thức (MultiProtocol Label Switching). Nó có thể thay thế quyết định chuyển tiếp gói tin (packets forwarding) và định tuyến IP (IP routing), không còn dựa trên trường IP header và bảng định tuyến mà thay vào đó nhãn sẽ được gắn vào gói tin. Phương thức này tăng tốc quá trình chuyển tiếp vì tra cứu node kế tiếp đơn giản hơn so với tra cứu bởi bảng định tuyến.
  • MPLS giúp dễ dàng tạo các “liên kết ảo” giữa các node trong mạng, bất chấp giao thức mã hóa dữ liệu của chúng.
  • Trong một mạng MPLS, các gói dữ liệu được chỉ định nhãn. Quyết định chuyển tiếp gói tin được thực hiện hoàn toàn dựa trên nội dung các nhãn này, mà không cần kiểm tra các gói dữ liệu riêng của nó. Điều này cho phép tạo ra một mạch liên kết end-to-end thông qua các router, switch… sử dụng bất kỳ giao thức nào.
  • Một vài tính năng MPLS được hỗ trợ

    • Static Label binding cho IPv4
    • Giao thức phân phối nhãn (Label Distribution Protocol) cho IPv4
    • RSVP Traffic Engineering tunnels
    • Tự động phát hiện và báo hiệu dựa trên VPLS MP-BGP
    • MP-BGP dựa trên MPLS IP VPN




VPN

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-13

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-14


  • Hỗ trợ thiết lập kết nối an toàn, liên kết mã hóa sử dụng các phương pháp và các giao thức liên kết tunnel khác nhau.

    • Cho phép cấu hình các chế độ mạng thông suốt, liên kết đường hầm tunnel, IPsec, các giao thức mã hóa.
    • Liên kết đường hầm tunnel điểm-điểm
    • Cấu hình phân định VLAN chuẩn 802.1Q, hỗ trợ tạo các VLAN ảo…
    • Hỗ trợ tính năng độc quyền EoIP, là một giao thức liên kết tunnel Ethernet giữ hai thiết bị định tuyến trên một kết nối IP. Khi chức năng cầu liên kết của được kích hoạt, tất cả lưu lượng Ethernet sẽ được bắc cầu giống như là một cáp kết nối giữa hai router. Điều này giúp cho nhiều sơ đồ mạng có thể kết nối LAN bắc cầu qua Internet.



Mạng Không Dây (Wireless)

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-15


  • RouterOS hỗ trợ nhiều công nghệ vô tuyến, khả năng thích hợp cho thiết kế sử dụng các mạng WiFi hộ gia đình, hoặc xây dựng một mạng mesh công cộng diện rộng.

    • Chuẩn mạng vô tuyến 802.11a/b/g/n
    • Giao thức độc quyền Nstreme và Nstreme2
    • Cơ chế Client Polling
    • RTS/CTS
    • WDS
    • AP ảo
    • Access Control List
    • Roaming
    • WMM
    • Giao thức HWMP+
    • Giao thức định tuyến MME  


  • Giao thức không mạng không dây Nstreme và Nstreme2 cho phép mở rộng phạm vi kết nối và cải thiện tốc độ khi sử dụng router Mikrotik tại mỗi đầu. Ngoài ra Nstreme dual cũng được hỗ trợ cho phép sử dụng hai anten mỗi đầu, một để truyền và một cho nhận.


Công cụ hỗ trợ

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrotik%20RouterOS-congcuhotro


  • Để giúp quản lý mạng, RouterOS cung cấp nhiều công cụ cho phép quản lý và tối ưu mạng

    • Ping, tracer route
    • Bandwidth test, ping flood
    • Packet sniffer, torch
    • Telnet, SSH
    • E-mail and SMS send tools
    • Automated script execution tools
    • CALEA data mirroring
    • File Fetch tool
    • Active connection table
    • NTP Client and Server
    • TFTP server
    • Dynamic DNS updater
    • VRRP redundancy support
    • SNMP for providing graphs and stats
    • RADIUS client and server (User Manager)



Giấy phép (License)

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Mikrot10


  • Mỗi RouterOS đi kèm với một chứng chỉ giấy phép (License key) để được sử dụng mãi mãi và bắt buộc phải mua để có được nó.
  • Có 4 loại License key từ License L3 (level 3) - cấp thấp nhất với một số hạn chế cho đến License L6 – cấp cao nhất và không bị giới hạn tính năng
  • Mỗi thiết bị RouterBoard của Mikrotik đã được cài đặt trước một License RouterOS version và không yêu cầu mua thêm


Chứng chỉ của MikroTik


  • MTCNA   - MikroTik Certified Network Associate (view outline )
  • MTCRE    - MikroTik Certified Routing Engineer (view outline )
  • MTCWE   - MikroTik Certified Wireless Engineer (view outline )
  • MTCTCE  - MikroTik Certified Traffic Control Engineer (view outline )
  • MTCUME - MikroTik Certified User Management Engineer (view outline )
  • MTCINE  - MikroTik Certified Inter-networking Engineer (view outline )

      
Zone
Zone Ưu tú

Cấp bậc: Ưu tú

Bài viết : 792

Danh vọng : 1476

Uy tín : 0

Cài đặt MIKROTIK RouterOS


I. Giới thiệu chung :

MikroTik RouterOS là hệ điều hành dùng cho phần cứng RouterBOARD của MikroTik.

Tuy nhiên, điều tuyệt vời là RouterOS có thể cài đặt trên một máy tính bình thường để biến máy tính đó thành một con router tích hợp rất nhiều chức năng như: routing, firewall, bandwidth management, wireless access point, backhaul link, hotspot gateway, VPN server...v.v...

Trong bài viết này, Lê Cường sẽ hướng dẫn cài đặt Mikrotik RouterOS lên PC.

II. Các bước cài đặt cơ bản :

Miktotik RouterOS rất nhẹ nên chỉ cần một máy tính Pentium3 là chạy tốt.
Phiên bản 2.9x trở về trước chỉ chạy trên ổ cứng ata.

Bước 1 : Chuẩn bị các thứ cần thiết!

Truy cập http://www.mikrotik.com/download.html , chọn Devices là PC/ X86


1. Mikrotik OS router: là file .iso - image cdrom.
2. Winbox là phần mềm chạy trên windows , dùng cấu hình RouterOS theo giao diện.

Bước 2 : Ghi file .iso vừa tải về ở trên ra CD-ROM.

Bước 3 : Khởi động PC từ cd chứa RouterOS để tiến hành cài đặt.

- Trên màn hình sẽ hiện các tùy chọn các gói chức năng cần cài. Tùy theo nhu cầu sử dụng, chúng ta sẽ chọn cài các gói tương ứng. Ở đây, Tôi chọn hết.


Nhấn "a" để chọn tất cả, nhấn "i" để bắt đầu cài đặt.

Nó sẽ hiện ra 02 câu hỏi :

Bạn có muốn giữ lại cấu hình cũ không? N

Cảnh báo : tất cả dữ liệu sẽ bị xóa! Có tiếp tục không? Y



Quá trình cài đặt đã hoàn tất, rút cd ra khỏi PC rồi khởi động lại máy tính.

Sau khi khởi động lại máy tính, nó sẽ hiện ra màn hình đăng nhập.


Username : admin / Password : để trống

Bên dưới là màn hình dòng lệnh của Mikrotik RouterOS


*** Nó hỏi license kìa ^^! ***
 
III. Sử dụng Winbox để quản lý & cấu hình Mikrotik RouterOS :

Winbox là một tiện ích nhỏ dùng cho việc cấu hình phần mềm Mikrotik RouterOS bằng giao diện đồ họa một cách nhanh chóng và đơn giản.

Trước tiên, chúng ta cần đặt IP cho routerOS :


Dùng Winbox để kết nối :


Có thể kết nối đến Mikrotik Router bằng IP hoặc theo địa chỉ MAC đều được.


Giao diện cấu hình Mikrotik trong Winbox.


Các bạn từ từ khám phá nhé!

      
Zone
Zone Ưu tú

Cấp bậc: Ưu tú

Bài viết : 792

Danh vọng : 1476

Uy tín : 0

Cấu hình VPN Client To Site trên Mikrotik RouterOS


Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Topolo10

Trong bài viết này, Lê Cường sẽ hướng dẫn cấu hình nhanh VPN Client theo giao thức PPTP trên nền Mikrotik.

Lý thuyết về VPN thì các bạn tự tìm hiểu nhé! Xin không đề cập nữa. 

Mô hình bài lab này như sau :


Chúng ta sẽ sử dụng Winbox để cấu hình.

Cấu hình Mikrotik VPN Client To Site tuần tự theo các bước sau:

Cấu hình VPN trên Mikrotik theo giao thức PPTP.

Trên giao diện Winbox, click vào PPP ---> PPTP Server


Đánh dấu vào mục Enabled ---> OK


Qua tab Secrects ----> click vào dấu + màu đỏ để tạo user sử dụng VPN


Điền vào tên user, mật khẩu 


Điền vào Local Address và Remote Address

Local Address : có thể hiểu như là IP gateway của các user khi kết nối VPN.
Remote Address : IP sẽ cấp cho user khi kết nối VPN.


Sau khi điền xong các thông số trên thì click OK để hoàn tất việc cấu hình VPN Client To Site trên nền Mikrotik.

Việc cấu hình VPN trên Mikrotik RouterOS đã xong.

### Tạo kết nối VPN client trên Windows để kiểm tra

Ở đây, Tôi tạo kết nối VPN trên Windows 7. 

Vì trọng tâm của bài lab là cấu hình VPN trên Mikrotik RouterOS nên Tôi chỉ up vài hình ở phần này thôi nhé!







Tại tab Active Connections trên Winbox, Chúng ta sẽ thấy những user nào đang kết nối VPN.

      
Zone
Zone Ưu tú

Cấp bậc: Ưu tú

Bài viết : 792

Danh vọng : 1476

Uy tín : 0

Thiết lập hệ thống hotspot gatewway sử dụng mikrotik



Khái niệm Hotpspot là gì thì Lê Cường không nói đến lý thuyết nhé.

Theo khái niệm đơn giản của tôi thì Hotspot dùng để chia sẻ internet thông qua một mạng có dây hoặc không dây (Access point), chứng thực người dùng khi truy cập internet.

Khi người dùng kết nối đến hotspot và truy cập một trang web thì người dùng sẽ được dẫn đến trang đăng nhập của hotspot để yêu cầu nhập username/password chứng thực.

Hotspot thường được áp dụng trong các khu vực công cộng như: khách sạn, quán cafe, sân bay, trung tâm thương mại, .v.v... Ở những nơi này thì hotspot thường được cung cấp dưới dạng không dây.

Trong bài viết này, Tôi sẽ trình bày cách thiết lập một hệ thống Hotspot gateway sử dụng Mikrotik.

Chúng ta sẽ dùng Winbox để cấu hình nhanh.

Mô hình bài lab như sau :


Trong bài lab này, chúng ta cần 02 card mạng cho máy làm Hotspot Gateway.
Việc gán IP cho card mạng eth2 tương tự như eth1 nên tôi sẽ không nói đến nữa.

Bước tiếp theo là dùng Windox để kết nối đến Mikrotik RouterOS.

OK! không dài dòng nữa, vào đề thôi!

Cấu hình Mikrotik Hotspot tuần tự theo các bước sau:

Trong giao diện Winbox, Chúng ta chọn IP ==> Hotspot

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet 1

Chọn Hotspot Setup --> ether2 ---> Next


Local Address of Network: 172.16.0.254/24, chọn Masquerade Network --> Next


Cấu hình DHCP cho các máy client

Address Pool of Network : 172.16.0.1-172.16.0.253 --> Next


SSL certificate : None --> Next


Cấu hình DNS Server :



Tạo thông tin người dùng + mật khẩu để để sử dụng Hotspot


Cấu hình NAT :

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet 9


Click OK để hoàn tất cấu hình NAT.

Đến đây là cơ bản đã xong việc cấu hình Hotspot bằng Mikroktik RouterOS. Lúc này các máy client khi vào mạng sẽ nhận DHCP từ Hotspot Server, đăng nhập web sẽ thấy màn hình đăng nhập của Mikrotik xuất hiện, nhập vào account tạo sẵn ở trên là có thể truy xuất web bình thường.


* Cơm thêm : Để tùy chỉnh giao diên trang web chứng thực trong Hotspot theo ý khách hàng, chúng ta làm như sau:

Dùng ftp để chỉnh sửa các hình ảnh, file .html của hotspot.

      
Zone
Zone Ưu tú

Cấp bậc: Ưu tú

Bài viết : 792

Danh vọng : 1476

Uy tín : 0

Bộ phát wifi Indoor RB951Ui-2HnD & RB2011UiAS-2HnD-IN

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet 902_m
Bộ phát wifi Indoor RB951Ui-2HnD là dòng thiết bị 05 port chi phí thấp. Được thiết kế để sử dụng trong nhà, hữu dụng trong nhiều trường hợp với nhiều sự lựa chọn khác nhau. Sử dụng cho các doanh nghiệp vừa và nhỏ, văn phòng, cửa hàng, nhà nghỉ, ... Đặc biệt thiết bị MikroTIK RB951Ui-2HnD còn dùng để quản lý truy cập mạng (HotSpot Gateway) có dây hoặc không dây tại những nơi có mạng công cộng.

Thông số kỹ thuật RB951Ui-2HnD

• Chuẩn: 802.11 b/g/n
• Tần số: 2.4 Ghz
• Chế độ: AP
• Công suất phát : 1000mW
• Anten tích hợp sẵn: 2.5dBi
• Bảo mật: ....
• CPU : 600 MHz.
• Flash ROM : 128 MiB NAND Flash
• RAM : 128MB
• Ethernet port 10/100 : 5 port
• USP port : 1 port
• License level: 4
• Phụ kiện: Nguồn 8 - 30V

Tính năng nổi bật của WiFi MikroTIK RB951Ui-2HnD

• Hỗ trợ nhiều giao thức định tuyến : IPv4 là RIP v1/v2, OSPF v2, BGP v4 hoặc với IPv6 như Ripng, OSPFv3, và BGP.
• Firewall với tính năng: NAT, UPnP, QoS,... lọc thông qua địa chỉ IP, lớp mạng, các port hoặc giao thức IP, các thông tin phù hợp lớp 7.
• Chức năng HotSpot Gateway giúp việc quản lý truy cập mạng, tùy chọn hình thức truy cập, quảng cáo bằng trang chào...
• Web Proxy : HTTP, Transparent, SOCKs,...
• VPN: IPsec,VLAN chuẩn 802.1Q, tạo nhiều VLAN ảo, hỗ trợ tính năng EoIP,..
• QoS: Kiểm soát băng thông, thiết lập cơ chế kiểm soát tốc độ, cấu hình luu lượng.
• Công cụ hỗ trợ: Ping, tracer route, RADIUS client and server, Telnet, SSH...
• MPLS : Static Label binding cho IPv,RSVP Traffic Engineering tunnels, Tự động phát hiện và báo hiệu dựa trên VPLS MP-BGP,MP-BGP dựa trên MPLS IP VPN.
• Ngõ ra cấp POE trên cổng #5 - có thể đóng vai trò như PoE, cung cấp nguồn cho các thiết bị khác sử dụng mức điện áp tương ứng. Tải trọng điện tối đa trên port là 500mA.



Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet 682_m
Bộ phát wifi Indoor RB2011UiAS-2HnD-IN là dòng sản phẩm Router có hiệu năng tốt nhưng chi phí thấp chuyên trong nhà năng động: Định tuyến, điểm truy cập, tường lửa, MPLS, VPN, QoS, cân bằng tải và liên kết, cấu hình thời gian thực và giám sát - chỉ là một vài trong số lượng lớn các tính năng được hỗ trợ bởi RouterOS. Ngoài ra RB2011UiAS-2HnD-IN có 5 cổng Ethernet 1GB và 5 cổng Fast Ethernet nên nó được dùng làm Router trong doanh nghiệp vừa hoặc kết hợp với các thiết bị WiFi khác làm WiFi Công cộng (WiFi Hotspot) tại các quán cafe lớn, khách sạn vừa, ... nhờ vào tính năng Quản lý Người dùng Mạng (Hotspot Gateway) của RB2011UiAS-2HnD-IN.

RouterBOARD RB2011UiAS-2HnD-IN sử dụng Cổng RJ45 Serial thuận tiện trong việc cấu hình bằng command, cổng microUSB và chạy trên nền RouterOS L5, với Antenna Omni 4dBi giúp khu vực Server hoàn toàn không cần tới Cáp mạng kết nối cùng với màn hình cảm ứng LCD hiển thị đầy đủ thông số và hiệu năng.

Thông số kỹ thuật RB2011UiAS-2HnD-IN

• CPU: 600MHz (AR9344-DC3A-R)
• Flash ROM : 128 MiB NAND Flash
• RAM : 128MB (DDRAM II)
• SFP DDMI: 01 Port
• Serial port: RJ45
• License level: 5
• Port Gigabit 10/100/1000: 5 port 1GB (port thứ nhất có chức năng PoE)
• Port Lan 10/100: 5 Port Fast Ethernet 100Mbps
• Card mở rộng: 1 khe (Hỗ trợ thẻ nhớ MicroUSB type AB )
• Giám sát hiệu điện thế vào: Có
• Theo dõi nhiệt độ: Có (Nhiệt độ tốt nhất: -35C to +65C)
• Kích thước: 214mm x 86mm for PCB
• Jack nguồn hỗ trợ: 2 cổng
• Power: Cấp nguồn DC từ 10 đến 28V (công suất nguồn tối đa: 11W)
• 2 ăng-ten 4dBi Omni.



Công ty cổ phần ADTEK chuyên phân phối thiết bị mạng Mikrotik tại Việt Nam
Ms. Hồng (miền Bắc): Mobile 093.415.1992 - Email hongnt@adtek.vn
Mr. Quý (miền Nam): Mobile 098.652.080 ​- Email quynv@adtek.vn
      
Zone
Zone Ưu tú

Cấp bậc: Ưu tú

Bài viết : 792

Danh vọng : 1476

Uy tín : 0

Tính năng cấp nguồn PoE trên thiết bị Router Mikrotik

- Router Mikrotik hỗ trợ tính năng cấp nguồn PoE cho các thiết bị bên ngoài. Có thể tận dụng tính năng này cấp nguồn cho các thiết bị UBNT AP.
- Tính năng này chỉ làm thao tác chuyển nguồn, do đó nguồn cấp cho Mikrotik bao nhiêu sẽ được chuyển tiếp cho thiết bị cần cấp nguồn bấy nhiêu.

Các Router hỗ trợ PoE

RouterNguồn đi kèmCông suất tiêu thụ
tối đa
Số lượng Port
hỗ trợ PoE
Băng thông PortĐiều khiển nguồn
RB-201124 Vol x 0.8 A = 19.5 W6 W1 (port 5)100 MbpsTự động phát hiện thiết bị
có hỗ trợ PoE Passive.
RB-95124 Vol x 0.8 A = 19.5 W8 W1 (port 10)100 MbpsTự động phát hiện thiết bị
có hỗ trợ PoE Passive.

Tham khảo công suất tiêu thụ tối đa của các AP UBNT

Tên thiết bịĐiện năng tiêu thụ
tối đa (W)
BulletM27.0
Pico M28.0
Loco M25.5
Loco M55.5
Nano M28.0
Nano M58.0
AirGateway4.0
AirGateway-LR4.0
AirGrid M5-HP233.0
AirGrid M5-HP273.0
Rocket M26.5
Rocket M2 Ti6.5
Rocket M58.0
Rocket M5 Ti8.0
Rocket 5 AC lite8.5
Rocket 5 AC ptp8.5
PowerBeam 5AC-5008.5
PowerBeam 5AC-6208.5
UAP-AC (outdoor)22.0
UAP Outdoor8.0
UAP Outdoor + (plus)8.0
UAP-Pro12.0
UAP4.0

Công thức lựa chọn sản phẩm có số nguồn phù hợp


  • Công suất dư = công suất nguồn đi kèm(19.5) - (công suất Mikrotik + công suất Ubnt)
  • Thiết kế Công suất dư nên > 3 W


Vậy với port PoE của Mikrotik có thể cấp nguồn cho các thiết bị sau:

Tên thiết bịCông suất dư
Nano M219 – ( 8+8 ) = 3
Pico M219 – ( 8+7 ) = 4
UniFi UAP19 – ( 8+4 ) = 7
UniFi UAP-LR19 – ( 8+6 ) = 5
Airgateway19 – ( 8+4 ) = 7
và các thiết bị khác tùy tính toán...

Kết luận


  • Port PoE-Out của Mikrotik hoàn toàn tương thích với thiết bị AP (tùy dòng sản phẩm) của Ubnt.
  • Tính ổn định chưa đo được trong điều kiện thực tế. Trong khi thử nghiệm thấy rằng thiết bị Ubnt không bị ảnh hưởng gì đến chất lượng và hiệu năng.
  • Do số lượng port hỗ trợ PoE của Mikrotik chỉ có 1 nên tính năng này đưa ra thêm một ít tiện ích cho người sử dụng.

      
Office
Office Ưu tú

Cấp bậc: Ưu tú

Giới tính : Nam

Bài viết : 807

Danh vọng : 1653

Uy tín : 10

Router CCR1009-8G-1S-1S+ cho doanh nghiệp


Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet 917_l

CCR1009 8G 1S 1S+ là Router rất mạnh với 8 cổng Ethernet Gigabit và CPU 1.2Ghz, 9 lõi kép, 1 x SFP, 1 x SFP+, thiết kế với khung vỏ nhôm dạng tủ Rack (Rackmount 1U) dung lượng RAM 2Gb, 1 x serial port, 1x LCD cảm ứng, 1 x microUSB đồng thời có 2 nguồn dự phòng, hỗ trợ 802.3af/at trên Ether8. Thiết bị có thể đạt mức truyền tải một triệu gói mỗi giây.

CCR1009 hỗ trợ Performance lên đến 6Gbps có thể đáp ứng cho 1000 Kết nối đồng thời x 4 Mbps/ Kết nối được dùng làm Router tại các doanh nghiệp lớn (Enterprise) hoặc làm Quản lý Người dùng Truy cập cho các mạng WiFi Công cộng (WiFi Hotspot) tại khách sạn cao cấp, trung tâm thương mại, hội chợ triển lãm, ...

CCR1009-8G-1S-1S+ được nạp hệ điều hành RouterOS. Đây là hệ điều hành đầy đủ tính năng như:

- Định tuyến động (dynamic routing)
- Quản lý Người dùng Mạng WiFi Công cộng (WiFi Hotspot)
- Tường lửa
- Nghi thức MPLS
- Hỗ trợ VPN
- Hỗ trợ Chất lượng Dịch vụ nâng cao (QoS)
- Cân bằng tải / Bonding
- Giám sát theo thời gian thực.  

... và còn rất nhiều các tính năng khác được hỗ trợ bởi RouterOS.

Thông số kỹ thuật CCR1009-8G-1S-1S+

- CPU: 1,2Ghz (TLR4-00980CG-10CE  - 9 Nhân)
- SFP DDMI: 2 Cổng
- Màn hình hiển thị hiệu suất:
- Architecture: TILE
- RAM: 2GB (DDRAM II)
- Port Ethernet 10/100/1000: 8 Port (mỗi cổng đều 1GB)
- Port USB: 1 Cổng (microUSB type AB)
- Jack Nguồn: 2 x IEC C14 AC 110/220V
- PoE IN: 802.3af support (12-58V) (not OUT) (eth8)
- Hệ điều hành hỗ trợ: RouterOS v6 (nhân Linux)
- Quản lý CPU, RAM, thời gian:
- Serial port: RS232 + Header
- Giám sát hiệu điện thế vào:
- Theo dõi nhiệt độ:
- Nhiệt độ tốt nhất: -200C đến +600C
- Kích thước: 444 x 175 x 47mm

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet 812_l

Đặc điểm Module quang SFP 1.25Gbps

- Tương thích với chuẩn IEEE 802.3z 1250Base-SX, 1250Base-LX, 1250Base-ZX
- Tốc độ truyền dữ liệu của module quang 1.25Gbps
- Đặc tính MSA tự động điều chỉnh công suất - tương thích với chuẩn Công nghiệp Cage RFT
- Nguồn cấp Single +3.3V, giao diện TTL Logic
- Khoảng cách truyền xa 550m với Multi-mode và 120Km với Single-mode
- Hỗ trợ Hot Pluggable, chip EEPROM với chức năng Serial ID
- Giao diện quang LC Simplex/Duplex
- Ít nhiễu điện từ EMI
- Nhiệt độ hoạt động 0°C ~ +70°C (công nghiệp -40°C ~ +85°C)
- Laser Class 1 tương thích với IEC 60825-1 và IEC 60825-2
- Đạt tiêu chuẩn chất lượng RoHs

Lưu ý: Có thể phải dùng module quang SFP S-3553LC20D simplex nhưng chỉ tương thích với GPON 01 core

Tham khảo giá: 2.300.000 đ

Demo: http://demo.mt.lv

Tham khảo video cấu hình cơ bản của CCR 1036 , Cloud Router Switch , Configure Mikrotik Router as a switch .

Đánh giá kiểm tra thực tế:

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Router11

This document clarifies compatibility between MikroTik made SFP modules and MikroTik RouterBOARD hardware

ModelS-GPONS-RJ01S-85DLC05DS-31DLC20DS-3553LC20DS+85DLC03DS+31DLC10DS+2332LC10DSFP+ DAC
CCR1072-1G-8S++++++++++
CCR1036-12G-4S+++++++++
CCR1036-8G-2S++++++++++
CCR1016-12S-1S++ 1+ 1+ 1+ 1+ 1++++
CCR1009-8G-1S-1S++++++++++
CRS125-24G-1S+++++++++
CRS226-24G-2S++ 2-+ 2+ 2+ 2++++
CRS212-1G-10S-1S++ 1+ 1+ 1+ 1+ 1++++
CRS210-8G-2S++ 2-+ 2+ 2+ 2++++
CRS112-8G-4S+++++++++
CRS109-8G-1S+++++++++
RB3011+++++++++
RB2011+++++++++
RB260+++++++++
RB922/921+++++++++
RB953GS+++++++++
hAP AC+++++++++
FTC+++++++++

Legend:
Color codes:Not supportedCheck notes below

NOTES:


  • CCR1016-12S-1S+ / CRS212-1G-10S-1S+ -- SFP+1 interface does not work on any other link speed than 10G (does not support 1.25G fiber optic transceivers)

  • CRS226 / CRS210 -- Only SFP+1 interface supports SFP 1.25G fiber optic transceivers, SFP+2 works only with 10G transceivers/links.


Remote access from the Internet (WAN side):

[admin@MikroTik] > ip firewall filter add action=accept chain=input disabled=no dst-port=80 protocol=tcp

      
DuyHung
DuyHung Xuất sắc

Cấp bậc: Xuất sắc

Giới tính : Nam

Bài viết : 1226

Danh vọng : 2215

Uy tín : 31

Các kiểu cân bằng tải của Mikrotik

Sử dụng MIKROTIK RouterOS cho việc quản lý truy cập Internet Network-topology

Kiểu 1 : Chỉ cân bằng tải, không gộp băng thông

/ip firewall mangle

add action=mark-connection chain=input disabled=no in-interface=vnpt1 \
   new-connection-mark=to_vnpt1 passthrough=yes

add action=mark-connection chain=input disabled=no in-interface=vnpt2 \
   new-connection-mark=to_vnpt2 passthrough=yes

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
   no in-interface=vnpt1 new-connection-mark=to_vnpt1 passthrough=yes

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
   no in-interface=vnpt2 new-connection-mark=to_vnpt2 passthrough=yes

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
   no dst-address-type=!local in-interface=LAN new-connection-mark=\
   to_vnpt1 passthrough=yes per-connection-classifier=both-addresses:2/0

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
   no dst-address-type=!local in-interface=LAN new-connection-mark=\
   to_vnpt2 passthrough=yes per-connection-classifier=both-addresses:2/1

add action=mark-routing chain=prerouting connection-mark=to_vnpt1 disabled=\
   no in-interface=LAN new-routing-mark=to_vnpt1 passthrough=yes

add action=mark-routing chain=prerouting connection-mark=vnpt6_conn disabled=\
   no in-interface=LAN new-routing-mark=to_vnpt6 passthrough=yes

add action=mark-routing chain=output connection-mark=to_vnpt1 disabled=no \
   new-routing-mark=to_vnpt1 passthrough=yes

add action=mark-routing chain=output connection-mark=to_vnpt2 disabled=no \
   new-routing-mark=to_vnpt2 passthrough=yes

/ip firewall nat

add action=masquerade chain=srcnat disabled=no out-interface=vnpt1
add action=masquerade chain=srcnat disabled=no out-interface=vnpt2

/ip route

add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
   vnpt1 routing-mark=to_vnpt1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
   vnpt2 routing-mark=to_vnpt2 scope=30 target-scope=10

Kiểu 2 : Cân Bằng tải, Gộp băng thông download

/ip firewall mangle

add action=mark-connection chain=prerouting disabled=no in-interface=Lan_eth \
   new-connection-mark=to_vnpt1 passthrough=yesadd action=mark-connection chain=prerouting disabled=no in-interface=Lan_eth \
   new-connection-mark=to_vnpt2 passthrough=yes  add action=mark-routing chain=prerouting disabled=no in-interface=Lan_eth \
   new-routing-mark=to_vnpt1 passthrough=yes src-address-list=to_vnpt1add action=mark-routing chain=prerouting disabled=no in-interface=Lan_eth \
   new-routing-mark=to_vnpt2 passthrough=yes src-address-list=to_vnpt2  add action=mark-connection chain=prerouting connection-state=new disabled=no \
   in-interface=Lan_eth new-connection-mark=to_vnpt1 nth=2,1 passthrough=yesadd action=mark-connection chain=prerouting connection-state=new disabled=no \
   in-interface=Lan_eth new-connection-mark=to_vnpt2 nth=2,2 passthrough=yes  add action=add-src-to-address-list address-list=to_vnpt1 address-list-timeout=\
   1d chain=prerouting connection-mark=to_vnpt1 disabled=no in-interface=\
   Lan_ethadd action=add-src-to-address-list address-list=to_vnpt2 address-list-timeout=\
   1d chain=prerouting connection-mark=to_vnpt2 disabled=no in-interface=\
   Lan_eth  add action=mark-routing chain=prerouting connection-mark=to_vnpt1 disabled=no \
   in-interface=Lan_eth new-routing-mark=to_vnpt1 passthrough=yesadd action=mark-routing chain=prerouting connection-mark=to_vnpt2 disabled=no \
   in-interface=Lan_eth new-routing-mark=to_vnpt2 passthrough=yes  /ip firewall natadd action=masquerade chain=srcnat disabled=no out-interface=vnpt1add action=masquerade chain=srcnat disabled=no out-interface=vnpt2 /ip routeadd check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
   vnpt1 routing-mark=to_vnpt1 scope=30 target-scope=10add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
   vnpt2 routing-mark=to_vnpt2 scope=30 target-scope=10

Kiểu 3 : Cân bằng tải, Gộp băng thông download và upload

/ip firewall mangle

add action=mark-connection chain=input disabled=no in-interface=vnpt1 \
   new-connection-mark=to_vnpt1 passthrough=yesadd action=mark-connection chain=input disabled=no in-interface=vnpt2 \
   new-connection-mark=to_vnpt2 passthrough=yesadd action=mark-routing chain=output connection-mark=to_vnpt1 disabled=no \
   new-routing-mark=to_vnpt1 passthrough=yesadd action=mark-routing chain=output connection-mark=to_vnpt2 disabled=no \
   new-routing-mark=to_vnpt2 passthrough=yesadd action=accept chain=prerouting disabled=no dst-address=192.168.0.0/24 \
   in-interface=Lan_ethadd action=mark-connection chain=prerouting disabled=no dst-address-type=\
   !local in-interface=Lan_eth new-connection-mark=to_vnpt1 passthrough=yes \
   per-connection-classifier=both-addresses-and-ports:2/0add action=mark-connection chain=prerouting disabled=no dst-address-type=\    !local in-interface=Lan_eth new-connection-mark=to_vnpt2 passthrough=yes \
   per-connection-classifier=both-addresses-and-ports:1/1add action=mark-routing chain=prerouting connection-mark=to_vnpt1 disabled=no \
   in-interface=Lan_eth new-routing-mark=to_vnpt1 passthrough=yesadd action=mark-routing chain=prerouting connection-mark=to_vnpt2 disabled=no \
   in-interface=Lan_eth new-routing-mark=to_vnpt2 passthrough=yes  /ip firewall natadd action=masquerade chain=srcnat disabled=no out-interface=vnpt1add action=masquerade chain=srcnat disabled=no out-interface=vnpt2 /ip routeadd check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
   vnpt1 routing-mark=to_vnpt1 scope=30 target-scope=10add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
   vnpt2 routing-mark=to_vnpt2 scope=30 target-scope=10

Hướng dẫn load blancing mikrotik 2 WAN(PPPoE) to 1 LAN

nguồn (http://www.easyzonecorp.net/network/view.php?ID=1390 ) copy dán vào chạy.

Script : 2 WAN(PPPoE) to 1 LAN

#|/ip address
/ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether5 comment=”default configuration”
#|/ip firewall mangle
/ip firewall mangle add chain=input in-interface=pppoe-out1 action=mark-connection new-connection-mark=ether1_conn
/ip firewall mangle add chain=input in-interface=pppoe-out2 action=mark-connection new-connection-mark=ether2_conn
/ip firewall mangle add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1
/ip firewall mangle add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2
/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=ether1_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether1
/ip firewall mangle add chain=prerouting connection-mark=ether2_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether2
#|/ip route
/ip route add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_ether1 check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_ether2 check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=pppoe-out1 distance=1 check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=pppoe-out2 distance=2 check-gateway=ping
#|/ip firewall nat
/ip firewall nat add chain=srcnat out-interface=pppoe-out1 action=masquerade
/ip firewall nat add chain=srcnat out-interface=pppoe-out2 action=masquerade
#| DHCP server is on switch, with address pool 192.168.0.100-192.168.0.200
/ip pool add name=default-dhcp ranges=192.168.0.100-192.168.0.200
/ip dhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
/ip dhcp-server network add address=192.168.0.0/24 gateway=192.168.0.1 dns-server=192.168.0.1 comment=”default configuration”
#| DNS
/ip dns set allow-remote-requests=yes
/ip dns static add name=router address=192.168.0.1
#| Now Configure DNS server so users can resolve hostnames,
#| Ex.cache-size=5000KiB
#| DNS Google = 8.8.8.8,8.8.4.4
#| DNS 3BB = 110.164.252.222,110.164.252.223
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000K max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4

Sau khi chạy script xong chỉnh 1 chút là thành load PCC (tận dụng PC cũ và LAN cùi sẽ làm được

+ETHER1: WAN VNPT
+ETHER2: WAN VIETTEL
+ETHER3: LOCAL


      
      

Xem chủ đề cũ hơn Xem chủ đề mới hơn Về Đầu Trang  Thông điệp [Trang 1 trong tổng số 1 trang]

Quyền hạn của bạn

Bạn không có quyền trả lời bài viết
free counters



  • Đoàn Ngọc Khánh

    mobile phone 098 376 5575


    Đỗ Quang Thảo

    mobile phone 090 301 9666


    Nguyễn Văn Của

    mobile phone 090 372 1401


    IP address signature
    Free forum | © PunBB | Free forum support | Liên hệ | Báo cáo lạm dụng | Thảo luận mới nhất