Change background image
LOVE quotion

Bắt đầu từ 4.53' thứ Hai ngày 17/10/2011


You are not connected. Please login or register

Xem chủ đề cũ hơn Xem chủ đề mới hơn Go down  Thông điệp [Trang 1 trong tổng số 1 trang]

KHCN
KHCN Ưu tú

Cấp bậc: Ưu tú

Giới tính : Nam

Bài viết : 788

Danh vọng : 1604

Uy tín : 23

[Hướng dẫn] Load-Balance với Multiwan của OpenWrt

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Intern10

Giới thiệu:

Firmware Openwrt là fw nguồn mở có rất nhiều tính năng hay ho, chạy được trên nhiều loại phần cứng router khác nhau. Bài viết này CQA xin giới thiệu cách dùng fw openwrt để biến router wifi 1 port wan bình thường thành router load balancing với nhiều đường wan khác nhau.

Điều kiện cần & đủ:

- Bất cứ router wifi nào chạy được openwrt, bài viết này CQA dùng con Buffalo wzr-hp-ag300h. Khuyến cáo không nên dùng router có cpu dưới 300mhz, flash rom dưới 8MB & ram dưới 32MB, nếu bạn ko muốn con router của mình tèo sớm.
- Firmware Openwrt: tối thiểu là Attitude Adjustment 12.09 hoặc mới hơn. Download tại openwrt.org
- Bất cứ phần mềm SSH chạy trên win nào, để ta login vô router (ví dụ Putty), ai xài linux thì ko cần phải nói nữa.
- Phải có ít nhất 2 đường Internet.
- Cách flash fw openwrt sẽ không nói, giả định là bạn đã flash thành công rồi nhé.
- Cà fê, thuốc lá, đồ ăn nhẹ, vợ/bạn gái... để vừa làm vừa relax.

Các bước làm như sau:

- Đầu tiên dùng giao diện web config đường wan1, lấy cổng wan mặc định của router, tạo kết nối internet để cài những gói cần thiết. Trong hình CQA dùng kiểu kết nối pppoe, tuỳ thực tế bạn có thể tạo kiểu static, dhcp... nào cũng được.

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Wan1

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Wan1a

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Wan1b

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Wan1c

- Sau khi đã có kết nối internet wan1 & kiểm tra đã ra được internet tốt, dùng ct ssh login vô router, ở đây CQA dùng Putty. Rồi chạy 2 lệnh sau:

opkg update
opkg install luci-app-multiwan luci-app-qos luci-app-p2pblock luci-app-upnp


Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Opkg

- Ở vd này CQA sẽ dùng wifi làm kết nối internet, tạo 2 đường wan2 wan3 từ interface wifi b/g/n.

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Wan2_wifi

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Wan2_wifia

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Wan3_wifia

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Wan_statics

Như hình trên, wan2 wan3 chạy mode client câu sóng từ 2 AP khác để làm đường wan.

-Tiếp theo tới bước config ip cho wan2 wan3, như hình dưới CQA dùng kiểu static ip tĩnh.

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Iface0c

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Iface0a

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Iface0b

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Iface1a

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Iface1b

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Iface_statics

Nhớ chỉ định zone cho đúng, wan1 wan2 wan3 phải thuộc zone wan, có màu đỏ.

- Nếu ta muốn config mấy cổng LAN của router làm đường wan thì sao ? Vd CQA chỉ định port1 là vlan2 eth0.2. Lúc này interface LAN phải đưa qua Vlan1 eth0.1. Mời xem hình ví dụ:

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Laneth0_1

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Vlan1

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Vlan2

- Bây giờ ta config phần Multiwan:

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Mwan1

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Mwan2

Nhớ khi add interface phải đặt tên cho đúng với tên wan ta đã đặt từ trước, ở đây là wan1 wan2 wan3. Bạn có thể config Multiwan tuỳ theo yêu cầu thực tế & trí tưởng tượng của bạn, không nhất thiết phải như hình.

- Giờ config QoS, cái này là tuỳ chọn, không bắt buộc.

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Qos

- Kiểm tra tab Startup, đảm bảo mọi thứ phải được enable, cái nào chưa enable thì em nó lên.

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Startup

Sau khi config xong, nhớ save&apply, reboot lại router. Kiểm tra lại tình trạng multiwan có OK ko ?

- Cách kiểm tra từng đường wan xem có hoạt động tốt ko bằng cách xác định tên của kết nối wan:

ifconfig

gõ từng lệnh sau để kiểm tra từng đường wan:

ping -w 1 -I pppoe-wan1 google.com
ping -w 1 -I wlan0-1 yahoo.com
ping -w 1 -I wlan0-2 microshit.com


Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải Mwan_status

Vậy là xong rồi đó. CQA chỉ có điều kiện test thực tế với router có cpu atheros, ai dùng phần cứng khác mà gặp lỗi hay vấn đề gì đó muốn đặt câu hỏi xin vui lòng mô tả cụ thể phần cứng, cách config, cấu trúc mạng... Mọi câu hỏi ko đầy đủ thông tin CQA sẽ ko trả lời.

Hẹn các bạn bài viết sau, sẽ hướng dẫn cách cài MWAN3, là chương trình tương tự như Multiwan, có cách config linh động & cũng phức tạp hơn, nhưng chạy ổn hơn. Thân mến.

Theo CQA - Tinh tế
      
KHCN
KHCN Ưu tú

Cấp bậc: Ưu tú

Giới tính : Nam

Bài viết : 788

Danh vọng : 1604

Uy tín : 23

[Hướng dẫn] Openwrt + MWAN3 = Load-Balance.

Tiếp theo phần hướng dẫn về Multi-Wan, CQA tiếp tục hướng dẫn các bạn dùng MWAN3 cùng với Openwrt Barrier Breaker 14.07 để biến bất cứ router wifi nào thành thiết bị cân bằng tải.

Mod Router Wifi 1 cổng Wan thành Router Cân Bằng Tải 02510

Yêu cầu cần thiết: 1 router wifi cài được openwrt, vd như tp-link TL-WR842ND v2 mình dùng trong bài này. Ít nhất 2 đường internet độc lập, vd như 1 đường qua adsl, 1 đường dùng nguồn wifi nào đó để ta repeater lại.

Ở bài viết này CQA sẽ ko post nhiều hình ảnh để tránh rối mắt, bài viết gọn gàng đơn giản. CQA sẽ coi như các bạn đã quen thuộc với giao diện cấu hình của Openwrt, đã biết cách làm chủ & cấu hình thông thạo các chức năng cơ bản của openwrt.

Thực hiện:

CQA sẽ dùng vd mô hình mạng như sau: WAN kết nối qua adsl, dùng dhcp client. WAN2 dùng wifi câu sóng từ 1 nguồn phát Internet, dùng dhcp client luôn.

Chạy WinSCP kết nối với router, duyệt tới thư mục /etc/config rồi edit file wireless để cấu hình wan2.

Đây là cấu hình vd của CQA: /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path 'platform/ar934x_wmac'
option htmode 'HT20'
option disabled '0'
option channel '1' ; chú ý: nếu vừa tiếp sóng vừa phát wifi thì phải đặt tất cả cùng kênh, router ko thể hoạt động trên 2 kênh khác nhau cùng lúc được đâu nhé.
option txpower '30'
option country 'US'

config wifi-iface
option network 'wan2'
option ssid 'Tên mạng muốn repeat'
option device 'radio0'
option mode 'sta'
option bssid 'địa chỉ MAC của tên mạng muốn repeat'
option encryption 'psk2+ccmp'
option key 'password của mạng muốn repeat'


Tiếp đến cấu hình phần network interfaces: /etc/config/network

config interface 'lan'
option force_link '1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option delegate '0'
option ipaddr '192.168.50.1'
option _orig_ifname 'eth1'
option _orig_bridge 'true'
option ifname 'eth1'

config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
option delegate '0'
option metric '10'

config interface 'wan2'
option proto 'dhcp'
option delegate '0'
option metric '20'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4'
option vid '1'


Chỉnh firewall để đưa wan2 vô zone WAN: /etc/config/firewall

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option network 'wan wan2'  <= sửa dòng này, mọi cái khác giữ nguyên.


Reboot lại router, rồi chạy 2 lệnh sau để kiểm tra chắc chắn 2 kết nối đã tạo ở trên đã ra được Internet:

ping -c 3 -w 2 -I eth0 yahoo.com
ping -c 3 -w 2 -I wlan0 yahoo.com


Chạy lệnh sau để cài mwan3, hoặc cài mwan3 qua Luci gui cũng được, cách nào cũng cho kết quả như nhau:

opkg update && opkg install luci-app-mwan3

Để chắc ăn reboot router lại lần nữa. Lúc này về cơ bản mwan3 đã chạy với cấu hình mặc định có sẵn.
Chúng ta có thể tinh chỉnh lại cấu hình mwan3 một chút cho tốt hơn: /etc/config/mwan3

config interface 'wan'
option enabled '1' ; nếu để là 0 thì sẽ disable wan
option reliability '2' ; chỉ định số server cần kiểm tra, có liên quan tới list track_ip, nếu khai báo track_ip là 2 địa chỉ thì chỗ này có thể để bằng hoặc thấp hơn tùy ý, không được để cao hơn số địa chỉ track_ip.
list track_ip '8.8.4.4' ; chỉ định địa chỉ ip server nào đó để mwan3 kiểm tra xem kết nối có thông không. tốt nhất nên để ip các dns server mà mình hay xài.
list track_ip '208.67.220.220' ; tương tự trên
option count '2' ; số lần ping tới mỗi server track_ip
option timeout '3' ; thời gian giây timeout của mỗi lần ping. đừng để quá thấp, tối thiểu nên trên 1s.
option interval '60' ; thời gian tính bằng giây giữa các lần kiểm tra. đừng để quá thấp hoặc quá cao.
option down '3' ; số lần kiểm tra thất bại trước khi mwan3 đưa đường wan này về chế độ offline.
option up '4' ; số lần kiểm tra thành công trước khi mwan3 đưa đường wan từ chế độ offline sang online.

config interface 'wan2'
list track_ip '8.8.8.8'
list track_ip '208.67.220.220'
option down '3'
option enabled '1'
option count '3'
option timeout '3'
option interval '60'
option up '4'
option reliability '2'


Ở trên CQA đã cắt ra chỉ điều chỉnh lại 2 phần config interface, phần còn lại các bạn có thể từ từ ngâm cứu sau. Phần giải thích ý nghĩa đã ghi ở trên, trước khi lưu lại file ta có thể xóa phần giải thích đi.

Reboot router lần nữa & log vào GUI xem lại những gì ta đã chỉnh có tác dụng như thế nào. Cái này CQA để các bạn tự khám phá sau.

Về cơ bản, cấu hình mặc định của mwan3 đã đủ xài, tùy yêu cầu mục đích thực tế mà ta có thể tùy chỉnh lại. Cái này CQA sẽ không nói chi tiết. Ai có thắc mắc & chỗ nào chưa hiểu thì hỏi mình sẽ giải thích & chỉ dẫn thêm.

Lời khuyên của mình là nên xài mwan3 thay thế cho Multi-wan, vì sao ? Vì mwan3 được cập nhật sửa lỗi & hỗ trợ thường xuyên. Tính năng của nó rất linh động & mạnh mẽ. Tốt hơn cái multi-wan khá nhiều.

Link hỗ trợ chính thức của tác giả mwan3 tại đâyhttps://forum.openwrt.org/viewtopic.php?id=39052
Hướng dẫn chính thức bằng tiếng Anh tại đâyhttp://wiki.openwrt.org/doc/howto/mwan3
      

Xem chủ đề cũ hơn Xem chủ đề mới hơn Về Đầu Trang  Thông điệp [Trang 1 trong tổng số 1 trang]

Quyền hạn của bạn

Bạn không có quyền trả lời bài viết
free counters



  • Đoàn Ngọc Khánh

    mobile phone 098 376 5575


    Đỗ Quang Thảo

    mobile phone 090 301 9666


    Nguyễn Văn Của

    mobile phone 090 372 1401


    IP address signature
    Free forum | © PunBB | Free forum support | Liên hệ | Báo cáo lạm dụng | Thảo luận mới nhất