Change background image
LOVE quotion

Bắt đầu từ 4.53' thứ Hai ngày 17/10/2011


You are not connected. Please login or register

Xem chủ đề cũ hơn Xem chủ đề mới hơn Go down  Thông điệp [Trang 1 trong tổng số 1 trang]

North
North Tích cực

Cấp bậc: Tích cực

Giới tính : Nam

Bài viết : 493

Danh vọng : 974

Uy tín : 3

Hướng dẫn cấu hình Router chạy OpenWRT để xem IPTV bằng các thiết bị hỗ trợ uPnP, DLNA

Bạn đã có đường truyền Internet + IPTV (MyTV của VASC, OneTV của FPT, NetTV của Viettel, ZTV của VTC...) mà muốn xem IPTV mọi lúc mọi nơi (trong nhà). Có lẽ cần sắm thêm 1 con LED cỡ 60"-70", 1 đầu HD xịn, Smartphone Galaxy S3, Note 2... có hỗ trợ uPnP là có thể thỏa mãn.


Nói vui vậy thôi, bất cứ thiết bị nào hỗ trợ DLNA, uPnP là có thể sử dụng phương pháp này mà không cần tới cái Set Top Box chết tiệt nữa. Tham khảo nội dung của hvcvuong, tienthanhbk từ diễn đàn HDvietnam để có hướng dẫn chi tiết.

Chuẩn bị :
- 1 Modem ADSL hoặc CPE quang, các bạn có cái nào dùng cái đó
- 1 Wireless Router đã up firmware OpenWRT
- Đã đăng ký Internet + IPTV

Hướng dẫn sau đây mình sử dụng ADSL Modem BlueCom "củ chuối", Wireless Router TP Link WR841ND v7 "củ khoai", chạy OpenWRT "củ hành":

PHẦN 1: Cấu hình và Đấu nối MODEM, ROUTER

Nói chung yêu cầu là :

Phần Modem

- Modem tắt DHCP, chỉ đặt 1 IP tĩnh cho nó để quản lý. Ví dụ 192.168.100.1
- Cấu hình PPPoE trên Modem để có Internet (hoặc Bridge PVC 8/35 đẩy sang cho Router thực hiện PPPoE) - lưu ý cái này, lát nói sau.
- Cấu hình Bridge PVC 8/37 (PVC có IPTV) vào 1 cổng nào đó để đẩy sang Router dùng làm nguồn chạy IPTV (ví dụ port 3, 4)

Giả sử Modem có 4 cổng, trên Modem sẽ có 2 nhóm:


  • Nhóm 1 Internet gồm Port 1, 2, PVC8/35
  • Nhóm 2 IPTV gồm Port 3, 4, PVC8/37


Thường thì làm công đoạn nhóm này trong phần Port Mapping. Các Modem khác nhau có thể khác.

Phần Router

- Router mở DHCP để có thể cấp IP cho Wireless hay Wire trong mạng LAN
- Nếu trên Modem đã thực hiện PPPoE thì Port WAN trên Router sẽ đặt ở chế độ Static IP, cùng lớp mạng với IP của Modem. Ví dụ 192.168.100.254, netmask 255.255.255.0, gateway 192.168.100.1.
Nếu Modem chỉ thực hiện Bridge PVC 8/35 thì Router phải set ở chế độ PPPoE, điền Username và Password vào là xong.
- Trên Router tạo thêm 1 Interface (Networks -> Interfaces -> Add new interface) đặt tên là IPTV_INTERFACE, đặt Interface này ở chế độ DHCP Client. Trong mục Physical Settings chọn VLAN interface eth0.1 (tức nhóm VLAN1 - là nhóm bao gồm tất cả các Port LAN trên Router). Mục đích bước này là để bạn cắm dây mạng là nguồn IPTV vào thì Interface này sẽ đảm nhận vai trò giao diện kết nối với luồng Multicast.

Đấu nối

- Kết nối Port 1 Modem (Internet) với Port WAN Router
- Kết nối Port 4 Modem (IPTV) với Port 4 Router (thực ra đấu vào port lan nào trên Router cũng được)

Lưu ý :

- Sau các bước trên thì phải đảm bảo từ Router có thể truy cập Internet (bất kể PPPoE ở Modem hay Router)
- Nếu PPPoE trên Modem thì dải IP giữa Modem và Router phải khác dải IP LAN trên Router.
Cụ thể ở ví dụ này: IP Modem là 192.168.100.1, IP WAN Router là 192.168.100.254 . Thì dải IP LAN trên Router phải khác dải này, sẽ đặt là 192.168.1.1 - 255.255.255.0 (cũng chính là IP quản lý Router).
- Nếu PPPoE trên Router thì có thể đặt IP LAN của Router trùng với dải của Modem, tốt nhất đặt trong dải 192.168.1.x trùng dải với IP quản lý Router 192.168.1.1
- Nên sử dụng PPPoE trên Router vì khi đó các PC trên Modem và Router sẽ cùng subnet nên có nghĩa chúng cùng 1 mạng. Còn nếu PPPoE trên Modem lúc này ta sẽ có 2 mạng LAN khác nhau.

**************************************************

Phần 2 : Cài đặt và cấu hình cho udpxy

1. Cài udpxy:

Mở Web LuCI của Router => System => Software => Action tab => bấm vào Update list => Mục Filter điền vào udpxy rồi bấm Find Package => Bấm Available Package chọn Install để cài udpxy.

**************************************************

2. Chỉnh sửa code : Mục này phải ăn tiền vì tiêu tốn bao nhiêu là time và nơ ron của mình

Dùng WinSCP login vào Router (Protocol là SCP, username và pass như của Web Interface)

- Vào mục etc/init.d/udpxy xóa hết nội dung cũ, chép nội dung dưới đây vào và lưu lại :

START=99
STOP=10

IGMP_OPTS="-p 4022 -a 192.168.1.1 -m 192.168.1.1"
IGMP_BIN="/usr/bin/udpxy"
PID_F="/var/run/udpxy.pid"

start() {
echo "Starting udpxy"
start-stop-daemon -S -x $IGMP_BIN -p $PID_F -b -m -- $IGMP_OPTS
}

stop() {
echo "Stopping udpxy"
start-stop-daemon -K -x $IGMP_BIN -p $PID_F -q
}

-----------------------------------------------------------------------

- Vào etc/config/firewall chép dòng này vào cuối file:

config rule
option src 'wan'
option proto 'igmp'
option target 'ACCEPT'

config rule
option src 'wan'
option proto 'udp'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'

config rule
option target 'ACCEPT'
option _name 'multicast'
option src 'wan'
option proto 'all'
option dest_ip '224.0.0.0/4'



**************************************************

3. Cài đặt xupnpd

Login vào WebUi của Router, tab Startup: Enable udpxy lên (nó hiện lên Enable có màu xanh lá cây là ok)

Chép nội dung sau vào mục Local startup (phía trên dòng exit 0), bấm Submit. Reboot lại router.
Bước này nhằm mục đích khi khởi động lại Router thì Router sẽ chạy các lệnh này để cài đặt uPnp một cách tự động. Chú ý là bắt buộc kết nối Internet bình thường, nhưng đừng lo cái này vì có Internet là chuyện nhỏ).

sleep 60
cd /tmp
wget http://dl.dropbox.com/u/54145509/xupnpd-rc12.tar.gz
tar zxvf xupnpd-rc12.tar.gz
rm xupnpd-rc12.tar.gz
cd xupnpd-rc/playlists
wget http://dl.dropbox.com/u/54145509/hoat_hinh.m3u
wget http://dl.dropbox.com/u/54145509/kenh_hd.m3u
wget http://dl.dropbox.com/u/54145509/kenh_nuoc_ngoai.m3u
wget http://dl.dropbox.com/u/54145509/kenh_viet_nam.m3u
wget http://dl.dropbox.com/u/54145509/true_sports.m3u
wget http://dl.dropbox.com/u/54145509/vtc_hd.m3u
cd ../
./xupnpd-ar71xx
ps
netstat -na
rm xupnpd-ar231x
cd /


Mấy dòng wget cuối là mấy kênh demo mình làm sẵn phục vụ các bạn. List này bao gồm cả MyTV (rtp) và SaiGonTV (udp) <- là thằng DiGiTV củ chuối. Bạn nào không  xem được 1 trong 2 loại hoặc muốn tùy biến thì có thể down về chỉnh sửa rồi up lên dropbox, lấy link trực tiếp thay thế vào link của mình là xong.

**************************************************

4. Kiểm tra và thưởng thức:

- Mở brower vào trang admin bằng IP của Router (192.168.1.1) và port 4044 : http://192.168.1.1:4044
- Vào tab playlists, sẽ thấy có mấy cái list mình khuyến mãi ở trên. Bạn nào thích đưa lên thêm thì chọn tới file .m3u của mình rồi bấm vào nút Send, sau đó quay lại nhấn Reload.

Lưu ý link kênh trong .m3u phải đúng định dạng http://192.168.1.1:4022/rtp/232.84.1.70:8394. Tham khảo trong file .m3u ở trên.

- Mở SmartTV hay HD Player lên hoặc VLC trên PC, Laptop, vào phần UPNP sẽ thấy xuất hiện mục UPNP-IPTV, chơi bất kỳ chương trình nào hiện trên list.
Xem thêm

- Xem IPTV với router chạy DDWRT, đơn giản trong cài đặt
- Giải pháp trộn Internet và MyTV, dùng router chạy firmware openwrt
      
North
North Tích cực

Cấp bậc: Tích cực

Giới tính : Nam

Bài viết : 493

Danh vọng : 974

Uy tín : 3

Giải pháp trộn Internet và MyTV, dùng router chạy firmware openwrt

Nếu nhà các bạn có nguồn MyTV (vnpt), Internet (viettel, fpt,...) riêng biệt, hoặc dùng cáp quang vnpt chạy cả 2 dịch vụ Internet và MyTV --> Muốn trộn 2 dịch vụ này ra 1 đường LAN hoặc wifi để tiện sử dụng thì đây là giải pháp.

Hiện trạng

- 1 line internet (có wifi) của bất kỳ nhà mạng nào, có cấp phát IP động
trong bài là router wifi có ssid: buffalo
- 1 line MyTV

Yêu cầu:

- 1 router chạy firmware openwrt
trong bài là tplink wr740n (khuyến cáo xài buffalo chạy ổn định hơn)
- 1 pc để cấu hình thiết bị
- đặt địa chỉ router chạy openwrt và modem internet khác dải ip

ví dụ:

modem internet 192.168.11.1
router openwrt 192.168.1.1

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet00

Thực hiện đúng trình tự:

1. Gắn dây Lan vào router openwrt
Factory reset router

2. Vào System --> Administrator --> Router Password, cài đặt mật khẩu cho router

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet01

3. Vào Network --> Wifi --> Wireless Overview

chọn Scan, sẽ thấy wifi có SSID là buffalo, chọn Join Network

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet02

điền mật khẩu wifi của modem internet (nếu có) vào ô WPA passphrase, chọn Submit

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet03

Tiếp theo chọn Save & Apply 

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet04

Kết quả: 

- router openwrt hoạt động ở chế độ wireless cilent
- pc (nối dây lan với router openwrt) đã có kết nối internet

4. Kết nối dây lan từ modem mytv tới cổng wan của router openwrt

Truy cập router openwrt, mục Network --> Interfaces --> WAN (eth1), chọn Edit 

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet05

mục Common Configuration --> Protocol, chọn Static address

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet06

chọn Switch protocol

mục IPv4 address chọn địa chỉ tùy ý (ko trùng địa chỉ modem, router, ví dụ: 10.0.0.2)
mục IPv4 netmask chọn 255.255.255.0

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet07

chọn Save & Apply

Quay lại mục Network --> Interfaces sẽ thấy WAN (eth1) có địa chỉ 10.0.0.2/24

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet08

5. Cài đặt trên router openwrt các soft udpxy và xupnpd theo hướng dẫn ở link 


Sửa lại 1 chút (rất quan trọng) như sau:

mở file udpxy
tìm đến dòng
OPTIONS="-T -S -p 4022"
sửa thành

OPTIONS="-T -S -p 4022 -m 10.0.0.2 -M 120 -B 1Mb"

dòng -m là địa chỉ nguồn của luồng muticast ta đã đặt ở trên

6. Reboot lại router openwrt

Thưởng thức thành quả:

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet09

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet10

Hướng dẫn cấu hình Router để xem IPTV Mytv-internet11

Trên hình, bbforever33 đang xem kênh starmovie, cùng lúc có kết nối Internet.
      
North
North Tích cực

Cấp bậc: Tích cực

Giới tính : Nam

Bài viết : 493

Danh vọng : 974

Uy tín : 3

Xem IPTV với router chạy DDWRT, đơn giản trong cài đặt

Yêu cầu:

- Router cài DDWRT, firmware tìm ở đây: Router Database | www.dd-wrt.com
- PC của các bạn đã xem được IPTV (bằng VLC) và có kết nối internet (từ cùng 1 cổng Lan trên modem)

Các bước thực hiện:

- cắm dây mạng từ cổng LAN trên Modem vào cổng WAN trên Router
- trên Router cài Static IP theo modem

thí dụ, địa chỉ modem:

Hướng dẫn cấu hình Router để xem IPTV 01

************************************************** *****************

router:

Hướng dẫn cấu hình Router để xem IPTV 02

************************************************** *****************
Hướng dẫn cấu hình Router để xem IPTV 03

************************************************** *****************

disable firewall:

Hướng dẫn cấu hình Router để xem IPTV 04

upload file list kênh iptv (.m3u) lên các host cho phép download directlink
thí dụ: dropbox.com, thư mục Public, chọn Copy public link

Hướng dẫn cấu hình Router để xem IPTV 20

như hình là file IPTV.m3u (MyTV của VNPT), link downloadhttp://dl.dropbox.com/u/68148815/IPTV.m3u

cấu trúc 1 kênh:

#EXTINF:10,ANTV
http://192.168.1.1:86/rtp/232.84.1.212:9246

- vào Administration --> Commands 

Hướng dẫn cấu hình Router để xem IPTV 21

paste đoạn code sau:

sleep 30
cd /tmp 

wget "http://dl.dropbox.com/u/68148815/udpxy_1.0-Chipmunk-19-1_ar71xx.ipk"
ipkg -d /tmp install udpxy_1.0-Chipmunk-19-1_ar71xx.ipk
rm udpxy_1.0-Chipmunk-19-1_ar71xx.ipk
usr/bin/udpxy -p 86 -B 2Mb -M 30

wget "http://dl.dropbox.com/u/68148815/pshare_0.0.2rc2_ar71xx.ipk"
ipkg -d /tmp install pshare_0.0.2rc2_ar71xx.ipk
rm pshare_0.0.2rc2_ar71xx.ipk
cd opt/share/pshare/playlists
wget "http://dl.dropbox.com/u/68148815/IPTV.m3u"
cd /tmp/opt/bin
./pshare -i 192.168.1.1 -n IPTV -t 1 -p 8888 -r "../share/pshare/www" "/tmp/opt/share/pshare/playlists"

chọn Save Starup

Hướng dẫn cấu hình Router để xem IPTV 22

kết quả:

Hướng dẫn cấu hình Router để xem IPTV 25

- qua Management
chọn Apply Settings
chọn tiếp Reboot Router

Hướng dẫn cấu hình Router để xem IPTV 23

Test: 


Hướng dẫn cấu hình Router để xem IPTV 26

Hướng dẫn cấu hình Router để xem IPTV 27

Hướng dẫn cấu hình Router để xem IPTV 28

Trên PC, chạy VLC, chọn View --> Playlist --> Local Network --> Universal Plug'n'Play

Hướng dẫn cấu hình Router để xem IPTV 29

Trên Adroid:

Hướng dẫn cấu hình Router để xem IPTV 31

Hướng dẫn cấu hình Router để xem IPTV 30

khuyên dùng BubbleUPnP vì tính năng search kênh

Hướng dẫn cấu hình Router để xem IPTV 34

Hướng dẫn cấu hình Router để xem IPTV 33
      
North
North Tích cực

Cấp bậc: Tích cực

Giới tính : Nam

Bài viết : 493

Danh vọng : 974

Uy tín : 3

Xem IPTV với TP-Link WR740N chạy OpenWRT

Tuy đã có topic hướng dẫn cấu hình router chạy openwrt để xem IPTV trên các thiết bị hỗ trợ UPNP, DLNA.
Nhưng với sự phổ biến của TP-LINK WR740N (gần như đi đâu cũng thấy, có lẽ do giá rẻ, hiệu năng ổn). Nên mình làm topic này hướng dẫn chi tiết cho các bác dễ cài đặt, sử dụng.

Yêu cầu:

+ đường truyền cáp đồng hoặc cáp quang, xem iptv được trên pc, dạng link udp:// hoặc rtp://
(vấn đề này mình sẽ làm 1 topic riêng, vì thông số cài đặt khác nhau đối với 
. mạng vnpt, mạng viettel
. mạng cáp đồng (vpi, vci), mạng cáp quang (vlan)
. các tỉnh khác nhau )

+ có đường truyền internet cho lần cài đặt đầu tiên (sau ko cần thiết nữa)
+ router WR740N
+ PC hoặc laptop chạy Windows

Thực hiện:

+ Download
- WinSCP, putty
WinSCP :: Download

- firmware openwrt cho WR740N
Index of /
có khuyến cáo firmware phù hợp với từng HW version khác nhau ở đây:
http://wiki.openwrt.org/toh/tp-link/tl-wr740n

1/ Up firmware openwrt cho wr740n từ firmware gốc
mình đang xài v4.24 nên up firmware:
http://downloads.openwrt.org/attitud...fs-factory.bin

2/ sau khi up xong, log in vào router với địa chỉ 192.168.1.1, user là root, password bỏ trống.
cắm dây mạng vào cổng wan, cài đặt cho router có kết nối internet

3/ vào System/Administration để cài đặt mật khẩu cho router

4/ mở putty, ssh vào router, địa chỉ 192.168.1.1, port 22, user là root, mật khẩu đã cài đặt ở trên

5/ paste các lệnh sau vào putty

opkg update
opkg install udpxy

6/ mở WinSCP, file protocol chọn scp, địa chỉ 192.168.1.1, port 22, user là root, mật khẩu đã cài đặt ở trên

7/ tìm đến file /etc/init.d/udpxy

8/ mở file udpxy

tìm đến dòng
OPTIONS="-T -S -p 4022"
sửa thành 
OPTIONS="-T -S -p 4022 -M 120 -B 1Mb"
(có thể tham khảo cấu trúc lệnh bằng cách vào putty đánh lệnh udpxy)

9/ trong file udpxy ở trên đã có hướng dẫn mở multicast traffic

10/ tìm đến file /etc/config/firewall

mở file firewall
thêm vào cuối nội dung sau:
config 'rule'
option 'target' 'ACCEPT'
option '_name' 'multicast'
option 'src' 'wan'
option 'proto' 'all'
option 'dest_ip' '224.0.0.0/4'


11/ paste các lệnh sau vào putty:

/etc/init.d/udpxy enable
/etc/init.d/udpxy start

12/ truy cập vào địa chỉ
192.168.1.1:4022/status
thấy các dòng sau là chạy udpxy thành công
Server Process ID Accepting clients on Multicast address Active clients

Tiếp theo ta cài đặt xupnpd để tạo upnp server, copy list kênh iptv

13/ do flash của wr740n còn trống không nhiều (~800KB) mà xupnpd gốc lại khá lớn (>500KB) nên ta cài đặt xupnpd lên ram (bộ cài xupnpd rút gọn nằm trên flash để khi khởi động lại router, ko cần internet, router vẫn tự động cài được)
- download bản xupnpd (194KB) do mình rút gọn từ bản xupnpd-1_03.tar.gz, đã update hot fix
http://dl.dropbox.com/u/68148815/xupnpd.tgz

list kênh mytv có thể tìm dễ dàng trên internet hoặc download ở đây:
http://dl.dropbox.com/u/68148815/MyTV.m3u
kênh trong list này có dạng rtp://

mở bằng wordpad hoặc notepad++ (Notepad++ v6.5.3 - Current Version),
tìm rtp://@
replace all bằng http://192.168.1.1:4022/rtp/

save lại, ta sẽ được list kênh dùng với xupnpd

hoặc download list kênh đã edit tại đây:
http://dl.dropbox.com/u/68148815/MyTV_xupnpd.m3u

cấu trúc 1 kênh, ví dụ Fashion TV
http://192.168.1.1:4022/rtp/232.84.1.2:7986

14/ mở WinSCP
copy 2 file xupnpd.tgz và MyTV.m3u (đã edit) vào flash của router, thư mục /root chẳng hạn

15/ tìm đến file /etc/rc.local
mở file rc.local, paste nội dung sau vào trước dòng exit 0

cd /tmp
tar zxf /root/xupnpd.tgz
cp /root/MyTV.m3u /tmp/xupnpd-rc/playlists/
/tmp/xupnpd-rc/xupnpd-ar71xx


16/ Khởi động lại router
truy cập vào địa chỉ
192.168.1.1:4044
ta sẽ thấy giao diện của xupnpd

17/ Gắn dây mạng có nguồn iptv vào cổng WAN của router
Trên PC, mở VLC, chọn View --> Playlist --> Local Network --> Universal Plug'n'Play --> UPnP-IPTV -->Playlists --> MyTV

Thành công !

Ảnh minh hoạ:


Hướng dẫn cấu hình Router để xem IPTV Wr740n02

Hướng dẫn cấu hình Router để xem IPTV Wr740n03

Hướng dẫn cấu hình Router để xem IPTV Wr740n04

Hướng dẫn cấu hình Router để xem IPTV Wr740n05

Hướng dẫn cấu hình Router để xem IPTV Wr740n06

Hướng dẫn cấu hình Router để xem IPTV Wr740n07

Hướng dẫn cấu hình Router để xem IPTV Wr740n08

Hướng dẫn cấu hình Router để xem IPTV Wr740n09

Hướng dẫn cấu hình Router để xem IPTV Wr740n10

Hướng dẫn cấu hình Router để xem IPTV Wr740n11

Hướng dẫn cấu hình Router để xem IPTV Wr740n12

Hướng dẫn cấu hình Router để xem IPTV Wr740n13

Hướng dẫn cấu hình Router để xem IPTV Wr740n14

Hướng dẫn cấu hình Router để xem IPTV Wr740n15

Hướng dẫn cấu hình Router để xem IPTV Wr740n16

Hướng dẫn cấu hình Router để xem IPTV Wr740n17

Hướng dẫn cấu hình Router để xem IPTV Wr740n18

Hướng dẫn cấu hình Router để xem IPTV Wr740n19
      
      

Xem chủ đề cũ hơn Xem chủ đề mới hơn Về Đầu Trang  Thông điệp [Trang 1 trong tổng số 1 trang]

Quyền hạn của bạn

Bạn không có quyền trả lời bài viết
free counters



  • Đoàn Ngọc Khánh

    mobile phone 098 376 5575


    Đỗ Quang Thảo

    mobile phone 090 301 9666


    Nguyễn Văn Của

    mobile phone 090 372 1401


    IP address signature
    Free forum | © PunBB | Free forum support | Liên hệ | Báo cáo lạm dụng | Thảo luận mới nhất